欢迎光临
我们一直在努力

首次安装Pycharm 2019.1.3版本时候 报错No Python interpreter selected的完美解决方案

No Python interpreter selected解决方案

由于博主之前一直使用的是sublime test 3编写python代码,今天由于工作需要,下载配置了Pycharm,但是在初次使用的时候报错No Python interpreter selected,这是因为我们初次下载后,解释器还没有配置完全,出现错误的原因主要有以下几点:

1. 没有将python.exe导入Pycharm (博主就是这种问题)

解决方案:

依次点击 Files-Settings 按下图所示

首次安装Pycharm 2019.1.3版本时候 报错No Python interpreter selected的完美解决方案插图
首次安装Pycharm 2019.1.3版本时候 报错No Python interpreter selected的完美解决方案插图(1)

在这里,点击右边的设置按钮的add,将python.exe解释器添加进System.interpreter中,即可以解决上述问题。

首次安装Pycharm 2019.1.3版本时候 报错No Python interpreter selected的完美解决方案插图(2)

2. 本地python环境没有配置好

cmd打开命令行,检查输入 python 检查python版本是否正确安装,如果没有安装好,访问python官网下载最新版的python

首次安装Pycharm 2019.1.3版本时候 报错No Python interpreter selected的完美解决方案插图(3)

3. python版本与Pycharm版本不匹配

解决这个问题的方法是重新下载Python3的一个可用版本进行安装,再按照上述添加python.exe的方法添加即可使用。

 收藏 (0) 打赏

您可以选择一种方式赞助本站

支付宝扫一扫赞助

微信钱包扫描赞助

avatar